[Standard Instance] Dashboard Latency

Incident Report for observeai

Resolved

The issue causing latency across dashboard tabs has now been resolved following the implementation of a fix. We continued monitoring the platform and services are operating normally at this time.

If the issue persists, please contact the Technical Support team for further assistance.
Posted May 27, 2026 - 15:49 UTC

Monitoring

A fix has been implemented and we are currently monitoring the results.
Posted May 27, 2026 - 13:05 UTC

Investigating

We are currently investigating an issue causing increased latency across multiple dashboard tabs. The team is actively debugging the issue and working to identify the root cause.
Posted May 27, 2026 - 12:34 UTC
This incident affected: Standard Instance (Instance Wide).