Users Experiencing Login Errors

Incident Report for observeai

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 17:37 UTC

Investigating

We are currently receiving multiple reports from users unable to log into the Observe platform.The engineering team is actively investigating the authentication flow and reviewing system logs to identify the root cause.
Posted Jul 22, 2026 - 14:15 UTC
This incident affected: Standard Instance (Login Page).