[Standard Instance] Interaction Processing Delay

Incident Report for observeai

Identified

Mitigation steps have been applied, and new incoming calls are processing normally now. We are currently reprocessing the delayed interactions impacted during the incident window, and the affected calls should start becoming available on the dashboard over the next few hours.

We will continue to monitor the recovery and share further updates as progress is made.
Posted May 27, 2026 - 16:39 UTC

Investigating

We are currently investigating an issue impacting interaction processing. As a result, the latest interactions may be delayed from appearing on the dashboard. Our teams are actively working on mitigation and we will share further updates as they become available.
Posted May 27, 2026 - 11:45 UTC
This incident affects: Standard Instance (Calls Tab).